Excel Prüfsumme bei Änderungen (ohne VBA/Makro)

Um in Excel eine Prüfsumme zu erstellen, welche einem zeigt, ob ein Dokument verändert wurde, gibt es viele Lösungen mittels VBA. Oft ist es jedoch nicht erlaubt Excel mit VBA Makros zu verwenden. Systemadministratoren sperren diese Funktion oft um Viren oder andere Sicherheitsprobleme zu vermeiden.

Ich beschreibe hier eine Lösung für eine Prüfsumme ohne VBA, also ein ganz gewöhnliches .xls oder xlsx Excel file.

Hier das Excel File zum herunterladen.
  1. Mit dieser Formel
    =WENN(A2=””,(ZEILE(A2)+SPALTE(A2)),ABS(COS((CODE(TEIL(A2,AUFRUNDEN(LÄNGE(A2)/9,0),1))(CODE(TEIL(A2,AUFRUNDEN(LÄNGE(A2)/5,0),1))+100)/CODE(TEIL(A2,AUFRUNDEN(LÄNGE(A2)/3,0),1))(CODE(TEIL(A2,AUFRUNDEN(LÄNGE(A2)8/9,0),1))+25)/CODE(TEIL(A2,AUFRUNDEN(LÄNGE(A2)6/9,0),1))(CODE(TEIL(A2,AUFRUNDEN(LÄNGE(A2)4/9,0),1))-25))/LÄNGE(A2)+CODE(A2))*(ZEILE(A2)+SPALTE(A2))))
    wird aus dem String in Zelle A2 eine Ziffer erzeugt.
    Die Formel wählt Zeichen aus dem String (TEIL), nimmt deren ASCII Wert (Code), zählt einen Fixwert hinzu um zu verhindern das die gleichen Zeichen an verschiedener Stelle den gleichen Wert liefern, multipliziert auf und macht am Ende eine Cosinus Funktion.
  2. Wir erzeugen mit der Formel eine zweite Tabelle welche für jedes graue Feld der original Tabelle eine Prüfsumme berechnet. Damit aber nicht Zellen mit dem gleichen Inhalt die gleiche Prüfsumme bekommen egal in welcher Spalte/Zeile sie sich befindet fügen wir zur Berechnung der Prüfsumme die Position hinzu mittels
    (ZEILE(A2)+SPALTE(A2)) .
  3. Damit leere Zellen keine Probleme bereiten verwenden wir WENN(A2=”” ….
  4. Wir summieren dann am Ende alle Werte der Prüfsummen aus der neuen Tabelle in eine finale Prüfsumme auf =REST(SUMME(A19:G29)*1000000,9999999) und stellen durch REST sicher das die finale Prüfsumme nicht zu viele Stellen bekommen kann.
  5. Die zweite Tabelle mit den einzelnen Prüfsummen kann man dann ausblenden und sperren damit niemand den Algorithmus sieht.

Diese Methode ist keine Kryptographie und auch nicht 100% sicher. Trotzdem bietet sie eine einfache Möglichkeit eine Prüfsumme für ein Excel Dokument zu erstellen ohne VBA und Makros zu verwenden.

Hinterlasse einen Kommentar.

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.